Information about the ticket

gusosasi

17 tickets19 comments

Error

Status: Closed

To PointsAPI

Guten Tag ich bekomme wenn ich das Plugin Points Api 1.6.5 oder so drauf habe in survival games einen fehler der wäre der hier:

[17:45:59 ERROR]: Could not pass event EntityDamageEvent to SurvivalGames v1.8.0

org.bukkit.event.EventException

> at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:310) ~[spigot-1.8

.8.jar:git-Spigot-76236cb-9cd1111]

> at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot-1.8.8

.jar:git-Spigot-76236cb-9cd1111]

> at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [spigot-1.8

.8.jar:git-Spigot-76236cb-9cd1111]

> at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487) [spigot-1.8

.8.jar:git-Spigot-76236cb-9cd1111]

> at org.bukkit.craftbukkit.v1_8_R3.event.CraftEventFactory.callEvent(CraftEventFactory.java:8

6) [spigot-1.8.8.jar:git-Spigot-76236cb-9cd1111]

> at org.bukkit.craftbukkit.v1_8_R3.event.CraftEventFactory.callEntityDamageEvent(CraftEventFa

ctory.java:552) [spigot-1.8.8.jar:git-Spigot-76236cb-9cd1111]

> at org.bukkit.craftbukkit.v1_8_R3.event.CraftEventFactory.handleEntityDamageEvent(CraftEvent

Factory.java:538) [spigot-1.8.8.jar:git-Spigot-76236cb-9cd1111]

> at org.bukkit.craftbukkit.v1_8_R3.event.CraftEventFactory.handleLivingEntityDamageEvent(Craf

tEventFactory.java:584) [spigot-1.8.8.jar:git-Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.EntityLiving.d(EntityLiving.java:1102) [spigot-1.8.8.jar:git

-Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.EntityHuman.d(EntityHuman.java:859) [spigot-1.8.8.jar:git-Sp

igot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.EntityLiving.damageEntity(EntityLiving.java:743) [spigot-1.8

.8.jar:git-Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.EntityHuman.damageEntity(EntityHuman.java:800) [spigot-1.8.8

.jar:git-Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.EntityPlayer.damageEntity(EntityPlayer.java:496) [spigot-1.8

.8.jar:git-Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.EntityLiving.K(EntityLiving.java:206) [spigot-1.8.8.jar:git-

Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.Entity.t_(Entity.java:247) [spigot-1.8.8.jar:git-Spigot-7623

6cb-9cd1111]

> at net.minecraft.server.v1_8_R3.EntityLiving.t_(EntityLiving.java:1448) [spigot-1.8.8.jar:gi

t-Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.EntityHuman.t_(EntityHuman.java:173) [spigot-1.8.8.jar:git-S

pigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.EntityPlayer.l(EntityPlayer.java:285) [spigot-1.8.8.jar:git-

Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java:382) [spigot-1.8.8.

jar:git-Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.PacketPlayInFlying.a(SourceFile:126) [spigot-1.8.8.jar:git-S

pigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.PacketPlayInFlying.a(SourceFile:8) [spigot-1.8.8.jar:git-Spi

got-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.run(SourceFile:13) [spigot-1.8.8.jar

:git-Spigot-76236cb-9cd1111]

> at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_131]

> at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_131]

> at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44) [spigot-1.8.8.jar:git-Spigot-76

236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:714) [spigot-1.8.8.ja

r:git-Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374) [spigot-1.8.8.ja

r:git-Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:653) [spigot-1.8.8.ja

r:git-Spigot-76236cb-9cd1111]

> at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:556) [spigot-1.8.8.

jar:git-Spigot-76236cb-9cd1111]

> at java.lang.Thread.run(Thread.java:748) [?:1.8.0_131]

Caused by: java.lang.IncompatibleClassChangeError: Expecting non-static method me.BukkitPVP.PointsAP

I.PointsAPI.addPoints(Lorg/bukkit/entity/Player;I)V

> at me.BukkitPVP.SurvivalGames.Utils.Points.addPoints(Points.java:24) ~[?:?]

> at me.BukkitPVP.SurvivalGames.Achievement.Manager.giveAchievement(Manager.java:87) ~[?:?]

> at me.BukkitPVP.SurvivalGames.Listener.AchievementListener.onDamage(AchievementListener.java

:59) ~[?:?]

> at sun.reflect.GeneratedMethodAccessor536.invoke(Unknown Source) ~[?:?]

> at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?

:1.8.0_131]

> at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_131]

> at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[spigot-1.8

.8.jar:git-Spigot-76236cb-9cd1111]

> ... 29 more

 

Mache ich aber 1.6.4 rein geht sg aber SkyWars geht nicht.

Ich hoffe sie können mir helfen.

Und bevor sie Fragen ich habe die Plugins geschenkt bekommen sie wurden Legal bezahlt und gekauft und sind nur bei mir im nutzen!

 

MFG gusosasi

By %user% %created%
%content%