The most common reason why a plugin is not loaded is that Java 8 is not installed. Basically all Mine-Home plugins need the latest Java version, so you should always keep them up to date.

How do I know which version of Java I have?

Basically, you can mostly look it up in the server settings of your hosting company. Also, the following error message is a good indicator of a wrong Java version:

org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError

How do I update my Java version?

Nitrado: You can edit your Java version in your Webinterface: Settings - General - Java - Java-Version.

Rootserver: Here you can download and install the latest version of Java. After that, you only have to change the path to the Java version in the startup file.

Other: If you are not aware of how you can change the Java version with your host, contact the support of your host.

% of people found this helpful.